Предпочтения в коде

Мне не нравится, когда в коде круглые скобки отделяют пробелами от содержимого, и пишут слитно с названием функции или другой конструкцией:

1
2
if( arg > 0 )
    doSomething( arg );

Видимо, считается, что это улучшает читаемость. Мне так не нравится — создаётся впечатление какой-то расхлябанности. Субъективно, но для меня достаточно, чтобы так не писать.

А если бы пришлось как-то обосновать такую точку зрения, хотя бы самому себе, я бы исходил из назначения строки. Например, роль первой строки — описать условие (if) — именно это слово и следует выделить. Смысл второй строки — действие (doSomething), это более значимая часть и её хорошо бы отделить визуально. А аргументы являются всего лишь дополнительной информацией.

Я стараюсь писать так:

1
2
if (arg > 0)
    doSomething (arg);

Так смотрится как-то собранней. Но если у функции, например, аргументов нет, глупо отделять её от пустых скобок. Тогда хорошо смотрится и doSomething();